Solved- Problem installing 5.4.2 - Deepin Linux

All Quick 'n Easy Web Builder support issues that are not covered in the forums below.
Post Reply
Star-Picket
Posts: 2
Joined: Sat Aug 25, 2018 4:49 am

Solved- Problem installing 5.4.2 - Deepin Linux

Post by Star-Picket » Sat Aug 25, 2018 10:00 am

Hi there,
I've just recently completed a fresh install of Deepin 15.7 (based on Debian unstable). When I tried to install the downloaded .deb file the in house Deepin package installer threw up some dependencies issues, namely, libcairo2:i386. Libcairo2 was already installed though, so I also installed the dev version for good measure. Qnew 5.4.2 still would not run. I then installed good old Gdebi (Gnome deb file installer) - it installed the 5.4.2 ,deb file without issue and sorted out the dependencies problem (the Deepin Package Manager has a way to go yet). But still, no working qnewb. I then tried the downloaded .zip alternative and tied to run the qnewb executable file, but still no luck.

In desperation I installed the Qnewb 4.4.2.8 and it ran okay. Just to see what would happen, I then tried the 5.4.2 executable file it also ran. This solved the issue.

I hope this will be of help to those having issues installing the 5.4.2 .deb file. Perhaps it was just my set up that was causing the problem.

Note also, in my previous version of Deepin 15.6, I did the upgrade to 5.4.2 and it worked okay, but I had an older version previously installed and working. I can only conclude that earlier versions of qnewb seem to have some things covered that have been perhaps over looked in the latest version. Of course this may well be a Deepin problem only.

Star-Picket
Posts: 2
Joined: Sat Aug 25, 2018 4:49 am

Re: Solved- Problem installing 5.4.2 - Deepin Linux

Post by Star-Picket » Sat Aug 25, 2018 10:20 am

One small annoying issue following the above work-around, is that every time I open qnewb I get the notification telling me to install FontAwesome which of course I have done. Another small issue that needs sorting.

Best regards

User avatar
Pablo
Site Admin
Posts: 2905
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Solved- Problem installing 5.4.2 - Deepin Linux

Post by Pablo » Sat Aug 25, 2018 9:08 pm

Did you install FontAwesome so that it's available for all applications?
You should not get this message if you the fonts was installed correctly.

Anyway, in the next version (planned for later this year) it will be installed automatically.

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests