How to install v. 6 on Linux?

All Quick 'n Easy Web Builder support issues that are not covered in the forums below.
Post Reply
jojopara
Posts: 4
Joined: Tue Oct 09, 2018 7:05 am

How to install v. 6 on Linux?

Post by jojopara » Tue Oct 09, 2018 10:10 am

Hello,

I have read, I hope, all the postings, but could not find a solution on how to install v. 6 on Linux. I am on Manjaro, a clone of Arch. Version 5 was successfully built from the repositories. Perhaps the new build will be available soon.

In the meantime, let us have a solution on version 6. I have downloaded and unpacked the Linux files. I have installed MS fonts. The software will not start. I have tried to installed with no success: libgtk2.0-0:i386; lib32-libpng12; lib32-gtk2; libgtk2.0-0:i386; GLIBC 2.24 - no packages were found. I am aware this may be specific to Manajaro.

Can version 6 be somehow overlapped on version 5?

I am posting this new thread as I saw the answers so far did not meet expectations.

User avatar
Pablo
Site Admin
Posts: 2905
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: How to install v. 6 on Linux?

Post by Pablo » Tue Oct 09, 2018 12:49 pm

Version 6 is a complete new version, build with the latest development tools.
It does not have the same requirements as version 5 which was build with older tools.

Version 6 should run on all recent distributions of Linux. If it does not work then this most likely means that libraries are missing.
If you run the application from the command line (in a terminal) then the system should tell you which libraries are missing.

jojopara
Posts: 4
Joined: Tue Oct 09, 2018 7:05 am

Re: How to install v. 6 on Linux?

Post by jojopara » Tue Oct 09, 2018 5:12 pm

I have read that this version has been made from scratch.

[jojo@new qnewb 6]$ qnewb
bash: qnewb: command not found

User avatar
Pablo
Site Admin
Posts: 2905
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: How to install v. 6 on Linux?

Post by Pablo » Tue Oct 09, 2018 5:52 pm

Did you install the correct version for your platform? (64bit vs 32bit)

jojopara
Posts: 4
Joined: Tue Oct 09, 2018 7:05 am

Re: How to install v. 6 on Linux?

Post by jojopara » Tue Oct 09, 2018 6:22 pm

I have downloaded again the 64-bit version just to be sure. The same.

I start wondering whhich is the executable file!? It is 'qnewb', isn't it?

The same is under Linux Mint 19 Tara. I do not want to use deb file there; I want to learn how to start it from an unpacked directory!

User avatar
Pablo
Site Admin
Posts: 2905
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: How to install v. 6 on Linux?

Post by Pablo » Wed Oct 10, 2018 6:06 am

i start wondering whhich is the executable file!? It is 'qnewb', isn't it?
Correct
I do not want to use deb file there;
But did you try? Installing the deb file should automatically install the missing libraries.

jojopara
Posts: 4
Joined: Tue Oct 09, 2018 7:05 am

Re: How to install v. 6 on Linux?

Post by jojopara » Wed Oct 10, 2018 7:57 am

Pablo wrote:
Tue Oct 09, 2018 5:52 pm
Did you install the correct version for your platform? (64bit vs 32bit)

Yes, the correct, 64-bit version is used.

My main OS is Manjaro Linux. I have Windows 8.1 and Linux Kin 19 Tara in virtual machine. I successfully installed them; on Mint using deb.

On Manjaro the attempt to install the deb package (which is not recommended at all) gave me:

sudo dpkg -i quick-n-easy-web-builder-6_6.0.2_amd64.deb
Selecting previously unselected package quick-n-easy-web-builder-6.
(Reading database ... 0 files and directories currently installed.)
Preparing to unpack quick-n-easy-web-builder-6_6.0.2_amd64.deb ...
Unpacking quick-n-easy-web-builder-6 (6.0.2) ...
dpkg: error processing archive quick-n-easy-web-builder-6_6.0.2_amd64.deb (--install):
unable to create new file '/var/lib/dpkg/info/quick-n-easy-web-builder-6.list-new': Operation not permitted
Errors were encountered while processing:
quick-n-easy-web-builder-6_6.0.2_amd64.deb

I still want to learn to run it the 'scientific' way with the qnewb command or better be able to install it!


Here is what I got when I gave the command another try:
sudo dpkg -i quick-n-easy-web-builder-6_6.0.2_amd64.deb
(Reading database ... 0 files and directories currently installed.)
Preparing to unpack quick-n-easy-web-builder-6_6.0.2_amd64.deb ...
Unpacking quick-n-easy-web-builder-6 (6.0.2) over (6.0.2) ...
dpkg: dependency problems prevent configuration of quick-n-easy-web-builder-6:
quick-n-easy-web-builder-6 depends on libx11-6; however:
Package libx11-6 is not installed.
quick-n-easy-web-builder-6 depends on libxxf86vm1; however:
Package libxxf86vm1 is not installed.
quick-n-easy-web-builder-6 depends on libsm6; however:
Package libsm6 is not installed.
quick-n-easy-web-builder-6 depends on libgtk-3-0; however:
Package libgtk-3-0 is not installed.
quick-n-easy-web-builder-6 depends on libpangocairo-1.0-0; however:
Package libpangocairo-1.0-0 is not installed.
quick-n-easy-web-builder-6 depends on libcairo2; however:
Package libcairo2 is not installed.
quick-n-easy-web-builder-6 depends on libgdk-pixbuf2.0-0; however:
Package libgdk-pixbuf2.0-0 is not installed.
quick-n-easy-web-builder-6 depends on libglib2.0-0; however:
Package libglib2.0-0 is not installed.
quick-n-easy-web-builder-6 depends on libpangoft2-1.0-0; however:
Package libpangoft2-1.0-0 is not installed.
quick-n-easy-web-builder-6 depends on libpango-1.0-0; however:
Package libpango-1.0-0 is not installed.
quick-n-easy-web-builder-6 depends on libfontconfig1; however:
Package libfontconfig1 is not installed.
quick-n-easy-web-builder-6 depends on libpng16-16; however:
Package libpng16-16 is not installed.
quick-n-easy-web-builder-6 depends on zlib1g; however:
Package zlib1g is not installed.
quick-n-easy-web-builder-6 depends on libc6; however:
Package libc6 is not installed.
quick-n-easy-web-builder-6 depends on libstdc++6; however:
Package libstdc++6 is not installed.
quick-n-easy-web-builder-6 depends on libgcc1; however:
Package libgcc1 is not installed.

dpkg: error processing package quick-n-easy-web-builder-6 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
quick-n-easy-web-builder-6

User avatar
Pablo
Site Admin
Posts: 2905
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: How to install v. 6 on Linux?

Post by Pablo » Wed Oct 10, 2018 11:15 am

It looks like a system related issue.

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests