Modal layer not o top

Issues related to previewing and publishing your web site.
Post Reply
mexman
Posts: 547
Joined: Mon Feb 11, 2013 11:33 am
Location: Puebla/Mexico

Modal layer not o top

Post by mexman »

Hi Pablo,
I found the modal layer not covering a master page.
Is that okay?In the workspace it looks well, but I need a modal layer to cover a master page contents too.
Maybe any setting which can do it?
Regards
Michael
PD.: Just sent the data to the support Email...sorry I sent many unnecessary images in the .zip
QnEWB V6.x - Ubuntu 18.04
User avatar
Pablo
Site Admin
Posts: 3353
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Modal layer not o top

Post by Pablo »

Note that this has nothing to do with the master page.
The page header on your master page is configured as 'In front of content'.
This means that it will be on top of everything else. So, it works as expected.
If you select 'Behind content' then the page header will no longer cover the modal.
mexman
Posts: 547
Joined: Mon Feb 11, 2013 11:33 am
Location: Puebla/Mexico

Re: Modal layer not o top

Post by mexman »

Great, thank you for the hint!
But unfortunately I am getting trouble.
I want the modal layer to appear on top of everything -> working
After closing the the modal layer, the menu is staying behind the scrolling page content.... of course, because I set the z-level of the menu to "behind everything"

There is an option missing, between "before" and "behind everything"
Instead the modal layer should have this option to be before everything, even if there is a menu behind which should stay always on top of the contents

Regards
Michael
QnEWB V6.x - Ubuntu 18.04
Post Reply